	
<!DOCTYPE html>
<html lang="it-it" dir="ltr">
<head>
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
		<meta charset="utf-8" />
	<base href="http://www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html" />
	<meta name="robots" content="index, follow" />
	<meta name="author" content="Tiberio &quot;Boss&quot; Redaelli" />
	<meta property="og:image" content="http://www.pokeritaliaweb.org/images/articoli/poker_online_postazione3_800.jpg" />
	<meta property="og:title" content=" Poker online MTT - A kurt111190 il NoS, S1mba98 si prende il Need for Speed. Deal tra RJ BARONE e sikkio81 nell'AoS" />
	<meta property="og:description" content="L'ha vinto 'kurt111190' il torneo più &quot;importante&quot; del venerdì sera. A segno anche 'S1mba98', protagonista nel Need, mentre 'BARONE' e 'sikkio81' si sono praticamente divisi l'AoS." />
	<meta name="description" content="L'ha vinto 'kurt111190' il torneo più &quot;importante&quot; del venerdì sera. A segno anche 'S1mba98', protagonista nel Need, mentre 'BARONE' e 'sikkio81' si sono praticamente divisi l'AoS." />
	<meta name="generator" content="Joomla! - Open Source Content Management" />
	<title> Poker online MTT - A kurt111190 il NoS, S1mba98 si prende il Need for Speed. Deal tra RJ BARONE e sikkio81 nell'AoS</title>
	<link href="http://www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.amp.html" rel="amphtml" />
	<link href="/templates/piw2017/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
	<link href="//www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html" rel="canonical" />
	<link href="http://www.pokeritaliaweb.org/plugins/content/fastsocialshare/style/style.css" rel="stylesheet" />
	<link href="/media/system/css/modal.css?f9cdc21f7a6df9771c4850cdaee2d55c" rel="stylesheet" />
	<link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css?f9cdc21f7a6df9771c4850cdaee2d55c" rel="stylesheet" />
	<link href="http://www.pokeritaliaweb.org//templates/piw2017/css/template.css?ts=1603526621" rel="stylesheet" />
	<link href="https://code.jquery.com/ui/1.12.1/themes/base/jquery-ui.css?f9cdc21f7a6df9771c4850cdaee2d55c" rel="stylesheet" />
	<link href="https://netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.css?f9cdc21f7a6df9771c4850cdaee2d55c" rel="stylesheet" />
	<link href="https://fonts.googleapis.com/css?family=Roboto:900" rel="stylesheet" />
	<link href="https://fonts.googleapis.com/css?family=Open+Sans+Condensed:300" rel="stylesheet" />
	<link href="https://fonts.googleapis.com/css?family=Orbitron" rel="stylesheet" />
	<link href="/modules/mod_jbcookies/assets/css/jbcookies.css?f9cdc21f7a6df9771c4850cdaee2d55c" rel="stylesheet" />
	<script type="application/json" class="joomla-script-options new">{"csrf.token":"2972ce9cfaa392dd0865f362989597a7","system.paths":{"root":"","base":""},"system.keepalive":{"interval":3600000,"uri":"\/component\/ajax\/?format=json"}}</script>
	<script src="/templates/piw2017/js/jui/bootstrap.min.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="/media/system/js/mootools-core.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="/media/system/js/core.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="/media/system/js/mootools-more.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="/media/system/js/modal.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="https://code.jquery.com/jquery-2.2.4.min.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="https://code.jquery.com/ui/1.12.1/jquery-ui.min.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="http://www.pokeritaliaweb.org//templates/piw2017/js/template.js?ts=1603526621"></script>
	<!--[if lt IE 9]><script src="/media/system/js/polyfill.event.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script><![endif]-->
	<script src="/media/system/js/keepalive.js?f9cdc21f7a6df9771c4850cdaee2d55c"></script>
	<script src="/media/system/js/html5fallback.js"></script>
	<script>
jQuery(function($){ initTooltips(); $("body").on("subform-row-add", initTooltips); function initTooltips (event, container) { container = container || document;$(container).find(".hasTooltip").tooltip({"html": true,"container": "body"});} });jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});
		jQuery(function($) {
			SqueezeBox.initialize({});
			initSqueezeBox();
			$(document).on('subform-row-add', initSqueezeBox);

			function initSqueezeBox(event, container)
			{
				SqueezeBox.assign($(container || document).find('a.modal').get(), {
					parse: 'rel'
				});
			}
		});

		window.jModalClose = function () {
			SqueezeBox.close();
		};

		// Add extra modal close functionality for tinyMCE-based editors
		document.onreadystatechange = function () {
			if (document.readyState == 'interactive' && typeof tinyMCE != 'undefined' && tinyMCE)
			{
				if (typeof window.jModalClose_no_tinyMCE === 'undefined')
				{
					window.jModalClose_no_tinyMCE = typeof(jModalClose) == 'function'  ?  jModalClose  :  false;

					jModalClose = function () {
						if (window.jModalClose_no_tinyMCE) window.jModalClose_no_tinyMCE.apply(this, arguments);
						tinyMCE.activeEditor.windowManager.close();
					};
				}

				if (typeof window.SqueezeBoxClose_no_tinyMCE === 'undefined')
				{
					if (typeof(SqueezeBox) == 'undefined')  SqueezeBox = {};
					window.SqueezeBoxClose_no_tinyMCE = typeof(SqueezeBox.close) == 'function'  ?  SqueezeBox.close  :  false;

					SqueezeBox.close = function () {
						if (window.SqueezeBoxClose_no_tinyMCE)  window.SqueezeBoxClose_no_tinyMCE.apply(this, arguments);
						tinyMCE.activeEditor.windowManager.close();
					};
				}
			}
		};
		
	</script>
	<script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js" integrity="sha384-Tc5IQib027qvyjSMfHjOMaLkfuWVxZxUPnCJA7l2mCWNIpG9mGCD8wGNIcPD7Txa" crossorigin="anonymous"></script>

	<!--[if lt IE 9]>
      <script src="https://oss.maxcdn.com/html5shiv/3.7.3/html5shiv.min.js"></script>
      <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <!--Start of Zopim Live Chat Script-->
		<script type="text/javascript">
		if (Math.min(window.screen.availHeight,window.screen.availWidth) > 480) {
		window.$zopim||(function(d,s){var z=$zopim=function(c){z._.push(c)},$=z.s=
		d.createElement(s),e=d.getElementsByTagName(s)[0];z.set=function(o){z.set.
		_.push(o)};z._=[];z.set._=[];$.async=!0;$.setAttribute('charset','utf-8');
		$.src='//cdn.zopim.com/?3iBARw2yrrmQCvrbO0z2oVZNYBdo3Lg9';z.t=+new Date;$.
		type='text/javascript';e.parentNode.insertBefore($,e)})(document,'script');
		}
		</script>
		<!--End of Zopim Live Chat Script-->
<link href="/media/system/css/modal.css?1603526621" rel="stylesheet" />
</head>
<body class="site com_content view-article no-layout no-task itemid-315">
	<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/it_IT/sdk.js#xfbml=1&version=v2.8";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
	<!-- Body -->
	<div class="container no-padding">
		<div class="delimiter">
		<div class="disclaimer hidden-xs">
			<div class="disclaimer-left">
				<p>Informati sulle probabilità di vincita e sul regolamento di gioco sul sito</p>
				<p><a target='_new' href='https://www.agenziadoganemonopoli.gov.it' rel='nofollow'>https://www.agenziadoganemonopoli.gov.it</a></p>
				
			</div>
			<div class="disclaimer-right">
				<img src="http://www.pokeritaliaweb.org//templates/piw2017/images/disclaimer.png" />
			</div>
			<div class="clear"></div>
		</div>
		
				<div class="logo">
			<img src='http://www.pokeritaliaweb.org/images/logo.png' alt='PIW Logo' title='Piw Logo' />
		</div>
				
				<nav class="navbar navbar-default">	
			<div class="container-fluid no-padding">
				<div class="navbar-header">
				<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1" aria-expanded="false">
					<span class="sr-only">Toggle navigation</span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
				</button>
				</div>
				<div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
					<ul class="menu nav navbar-nav">
<li class="item-101 default"><a href="/" class="fa fa-home fa-2x"></a></li><li class="item-300 dropdown parent"><a href="/poker-live.html" class="dropdown" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Poker Live</a><div class="dropdown-menu"><ul class="nav-child unstyled small"><li class="item-77"><a href="/poker-live/poker-italia.html" >Poker Italia</a></li><li class="item-78"><a href="/poker-live/poker-estero.html" >Poker Estero</a></li><li class="item-26"><a href="/poker-live/tornei-poker.html" >Tornei Poker</a></li></ul><div class='nav-articles hidden-xs'><div class='nav-article'><div><a href='/poker-live/poker-italia/35273-mondo-poker-perde-campione-gran-bravo-ragazzo-addio-matteo-mutti.html'><img src='http://www.pokeritaliaweb.org/images/articoli/matteo_mutti_wsop_circuit_800.jpg' /></a><br /><p><a href='/poker-live/poker-italia/35273-mondo-poker-perde-campione-gran-bravo-ragazzo-addio-matteo-mutti.html'>Il mondo del poker perde un campione e un gran bravo ragazzo, addio a Matteo Mutti</a></p></div></div><div class='nav-article'><div><a href='/poker-live/poker-italia/35123-intervista-fabio-backdoorak-peluso-primo-evento-123-scoop-giorno-davvero-magico-tra-laurea-e-vittoria.html'><img src='http://www.pokeritaliaweb.org/images/articoli/fabio_backdoorak_peluso_800.jpg' /></a><br /><p><a href='/poker-live/poker-italia/35123-intervista-fabio-backdoorak-peluso-primo-evento-123-scoop-giorno-davvero-magico-tra-laurea-e-vittoria.html'>Intervista a Fabio backdoorAK Peluso, primo nell'Evento #123 dello SCOOP: "E' stato un giorno davvero magico tra laurea e vittoria"</a></p></div></div><div class='nav-article'><div><a href='/poker-live/poker-italia/34844-diego-testa-piw-per-latte-siamo-apposto-adesso-testa-poker-festival-live-resta-sempre-mia-priorita.html'><img src='http://www.pokeritaliaweb.org/images/articoli/diego_testa_800.jpg' /></a><br /><p><a href='/poker-live/poker-italia/34844-diego-testa-piw-per-latte-siamo-apposto-adesso-testa-poker-festival-live-resta-sempre-mia-priorita.html'>Diego Testa a PIW: "Per il latte siamo apposto. Adesso testa al Poker Festival, il live resta sempre la mia priorità!"</a></p></div></div><div class='nav-article'><div><a href='/poker-live/poker-italia/34761-claudio-deseriis-sogno-portare-tana-delle-tigri-las-vegas-prossima-tappa-si-giochera-tra-febbraio-aprile.html'><img src='http://www.pokeritaliaweb.org/images/claudio_deseriis_tiberio_redaelli_tana2019.jpg' /></a><br /><p><a href='/poker-live/poker-italia/34761-claudio-deseriis-sogno-portare-tana-delle-tigri-las-vegas-prossima-tappa-si-giochera-tra-febbraio-aprile.html'>Claudio De Seriis: "Sogno di portare il Tana delle Tigri a Las Vegas. La prossima tappa si giocherà tra febbraio e aprile..."</a></p></div></div></div></div></li><li class="item-25 active dropdown parent"><a href="/poker-online.html" class="dropdown" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Poker Online</a><div class="dropdown-menu"><ul class="nav-child unstyled small"><li class="item-314"><a href="/poker-online/poker-high-stakes.html" >Poker High Stakes</a></li><li class="item-315 current active"><a href="/poker-online/poker-mtt-report.html" >Poker Mtt Report</a></li><li class="item-316"><a href="/poker-online/poker-online-news.html" >Poker Online News</a></li><li class="item-317"><a href="/poker-online/grinder-report.html" >Grinder Report</a></li></ul><div class='nav-articles hidden-xs'><div class='nav-article'><div><a href='/poker-online/poker-high-stakes/34055-poker-cash-game-online-chi-sono-giocatori-perdenti-in-tre-perso-67milioni-dollari.html'><img src='http://www.pokeritaliaweb.org/images/articoli/grafico-discesa.jpg' /></a><br /><p><a href='/poker-online/poker-high-stakes/34055-poker-cash-game-online-chi-sono-giocatori-perdenti-in-tre-perso-67milioni-dollari.html'>Poker Cash Game Online, ecco chi sono i giocatori che hanno perso di più. In tre sotto di 67milioni di dollari</a></p></div></div><div class='nav-article'><div><a href='/poker-online/poker-high-stakes/33562-spettacolo-jeju-triton-short-deck-call-epico-contro-andrew-robl-evento-millions-short-deck.html'><img src='http://www.pokeritaliaweb.org/images/andrew-robl-triton.png' /></a><br /><p><a href='/poker-online/poker-high-stakes/33562-spettacolo-jeju-triton-short-deck-call-epico-contro-andrew-robl-evento-millions-short-deck.html'>Spettacolo a Jeju al Triton Short Deck: call epico contro Andrew Robl nell’evento HKD$1 Millions Short Deck (VIDEO)</a></p></div></div><div class='nav-article'><div><a href='/poker-online/poker-high-stakes/33388-triton-high-roller-cash-game-jeju-4-way-all-in-pre-flop.html'><img src='http://www.pokeritaliaweb.org/images/rui-cao-triton-cash.jpg' /></a><br /><p><a href='/poker-online/poker-high-stakes/33388-triton-high-roller-cash-game-jeju-4-way-all-in-pre-flop.html'>Triton High Roller Cash Game - Spettacolo a Jeju con un 4-way all-in pre flop con piatto da oltre 800mila dollari</a></p></div></div><div class='nav-article'><div><a href='/poker-online/poker-high-stakes/33379-triton-high-roller-cash-game-tom-dwan-sotto-quasi-2-milioni-paul-phua-sopra-il-milione.html'><img src='http://www.pokeritaliaweb.org/images/articoli/tom-dwan-poker-after-dark.jpg' /></a><br /><p><a href='/poker-online/poker-high-stakes/33379-triton-high-roller-cash-game-tom-dwan-sotto-quasi-2-milioni-paul-phua-sopra-il-milione.html'>Triton High Roller Cash Game: Tom Dwan sotto di quasi 2 milioni, Paul Phua sopra il milione</a></p></div></div></div></div></li><li class="item-76 dropdown parent"><a href="/piw-editoriali.html" class="dropdown" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Editoriali</a><div class="dropdown-menu"><ul class="nav-child unstyled small"><li class="item-318"><a href="/piw-editoriali/poker-e-risate.html" >Poker e Risate</a></li><li class="item-319"><a href="/piw-editoriali.html" >Editoriali</a></li></ul><div class='nav-articles hidden-xs'><div class='nav-article'><div><a href='/piw-editoriali/poker-e-risate/31375-poker-e-risate-la-disquisizione-del-liquame-condiviso.html'><img src='http://www.pokeritaliaweb.org/images/articoli/liquidita_condivisa_800.jpg' /></a><br /><p><a href='/piw-editoriali/poker-e-risate/31375-poker-e-risate-la-disquisizione-del-liquame-condiviso.html'>Poker e Risate:  la disquisizione del liquame condiviso</a></p></div></div><div class='nav-article'><div><a href='/piw-editoriali/poker-e-risate/31272-poker-e-risate-quali-sono-le-bugie-più-utilizzate-dai-giocatori-di-poker.html'><img src='http://www.pokeritaliaweb.org/images/articoli/casino/pinocchio-800x600.jpg' /></a><br /><p><a href='/piw-editoriali/poker-e-risate/31272-poker-e-risate-quali-sono-le-bugie-più-utilizzate-dai-giocatori-di-poker.html'>Poker e Risate: quali sono le bugie più utilizzate dai giocatori di poker?</a></p></div></div><div class='nav-article'><div><a href='/piw-editoriali/poker-e-risate/31260-poker-e-risate-preparativi-per-le-wsope-e-fidanzamento-ufficiale-di-dan-bilzerian.html'><img src='http://www.pokeritaliaweb.org/images/articoli/casino/dansofia-800x600.jpg' /></a><br /><p><a href='/piw-editoriali/poker-e-risate/31260-poker-e-risate-preparativi-per-le-wsope-e-fidanzamento-ufficiale-di-dan-bilzerian.html'>Poker e Risate: preparativi per le Wsope e fidanzamento ufficiale di Dan Bilzerian</a></p></div></div><div class='nav-article'><div><a href='/piw-editoriali/poker-e-risate/31226-poker-e-risate-quando-il-fisco-vuole-più-soldi-di-quelli-che-hai-vinto-facendo-runner-up.html'><img src='http://www.pokeritaliaweb.org/images/articoli/casino/monopoly-800x600.jpg' /></a><br /><p><a href='/piw-editoriali/poker-e-risate/31226-poker-e-risate-quando-il-fisco-vuole-più-soldi-di-quelli-che-hai-vinto-facendo-runner-up.html'>Poker e Risate: quando il fisco vuole più soldi di quelli che hai vinto facendo runner up!</a></p></div></div></div></div></li><li class="item-56 dropdown parent"><a href="/strategie.html" class="dropdown" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Strategie</a><div class="dropdown-menu"><ul class="nav-child unstyled small"><li class="item-302"><a href="/strategie/poker-cash-game.html" >Poker Cash Game</a></li><li class="item-301"><a href="/strategie/poker-sit-go.html" >Poker Sit'n'Go</a></li><li class="item-303"><a href="/strategie/regole-del-poker.html" >Regole del Poker</a></li><li class="item-304"><a href="/strategie/heads-up.html" >Heads Up</a></li><li class="item-305"><a href="/strategie/poker-mindset.html" >Poker Mindset</a></li><li class="item-306"><a href="/strategie/poker-draw-games.html" >Poker Draw Games</a></li><li class="item-307"><a href="/strategie/poker-mtt.html" >Poker MTT</a></li><li class="item-310"><a href="/strategie/poker-omaha-games.html" >Poker Omaha Games</a></li></ul><div class='nav-articles hidden-xs'><div class='nav-article'><div><a href='/strategie/poker-cash-game/31906-poker-e-strategia,-per-vincere-giocando-a-poker-studia-bene-i-tuoi-avversari-al-tavolo-da-gioco.html'><img src='http://www.pokeritaliaweb.org/images/articoli/casino/Poker-High-Stakes-800x600.jpeg' /></a><br /><p><a href='/strategie/poker-cash-game/31906-poker-e-strategia,-per-vincere-giocando-a-poker-studia-bene-i-tuoi-avversari-al-tavolo-da-gioco.html'>Poker e Strategia, per vincere giocando a poker studia bene i tuoi avversari al tavolo da gioco</a></p></div></div><div class='nav-article'><div><a href='/strategie/poker-cash-game/27108-ale-torelli-spiega-tp-hero-fold-vs-mckeehen-2015.html'><img src='http://www.pokeritaliaweb.org/images/articoli/cappello/torelli-mckeehen.jpg' /></a><br /><p><a href='/strategie/poker-cash-game/27108-ale-torelli-spiega-tp-hero-fold-vs-mckeehen-2015.html'>Poker Cash game: Alec Torelli ci spiega un hero fold contro Joe McKeehen</a></p></div></div><div class='nav-article'><div><a href='/strategie/poker-cash-game/25478-quali-sono-i-tre-principali-errori-da-evitare-nel-poker-cash-game.html'><img src='http://www.pokeritaliaweb.org/images/articoli/fun/fold-foldare-poker-texasholdem.jpg' /></a><br /><p><a href='/strategie/poker-cash-game/25478-quali-sono-i-tre-principali-errori-da-evitare-nel-poker-cash-game.html'>Quali sono i tre principali errori da evitare nel poker cash game?</a></p></div></div><div class='nav-article'><div><a href='/strategie/poker-cash-game/23481-tre-errori-da-non-commettere-mentre-giochi-a-poker-cash-game.html'><img src='http://www.pokeritaliaweb.org/images/articoli/poker-online-mtt-grinding.jpg' /></a><br /><p><a href='/strategie/poker-cash-game/23481-tre-errori-da-non-commettere-mentre-giochi-a-poker-cash-game.html'>Tre errori da non commettere mentre giochi a poker cash game</a></p></div></div></div></div></li><li class="item-221"><a href="/gioco-online.html" >Gioco Online</a></li><li class="item-370"><a href="https://t.me/notiziepoker" target="_blank">Telegram</a></li><div class="clear"></div></ul>
												<div class="moduletable">
						<div class="hidden-sm search">
	<form action="/poker-online/poker-mtt-report.html" method="post" class="form-inline">
		<input name="searchword" id="mod-search-searchword" maxlength="200"  class="inputbox search-query" type="search" placeholder="Cerca sul sito..." /> <input type="image" alt="Vai" class="search-button" src="/templates/piw2017/images/searchButton.gif" onclick="this.form.searchword.focus();"/>		<input type="hidden" name="task" value="search" />
		<input type="hidden" name="option" value="com_search" />
		<input type="hidden" name="Itemid" value="293" />
	</form>
</div>
		</div>
	
									</div>
			</div>
		</nav>
				<div class="clear"></div>
		
				
				<div class="clear"></div>
		
									
		<div class="left col-sm-mod-9 col-sm-9 col-xs-12">
			<div id="system-message-container">
	</div>

						<div class="item-page" itemscope itemtype="https://schema.org/Article">
	<meta itemprop="inLanguage" content="it-IT" />
		

				
	
					
		
	
	
	<div class="pull-none" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img itemprop="image"
	class="caption" title="I risultati del venerdì sera..."	src="http://www.pokeritaliaweb.org/images/articoli/poker_online_postazione3_800.jpg" alt="I risultati del venerdì sera..." /> 
	<meta itemprop="url" content="http://www.pokeritaliaweb.org/images/articoli/poker_online_postazione3_800.jpg">
    <meta itemprop="width" content="800">
	<meta itemprop="height" content="520">	
	</div>
		
			<h2 itemprop="headline">
			 Poker online MTT - A kurt111190 il NoS, S1mba98 si prende il Need for Speed. Deal tra RJ BARONE e sikkio81 nell'AoS		</h2>
		
		
	<div class="left-article col-sm-9 no-left-padding">
		
	<div itemprop="mainEntityOfPage" itemscope itemtype="https://schema.org/WebPage"></div>
		
	<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
		<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
		<meta itemprop="url" content="http://www.pokeritaliaweb.org/"images/logo.png">
		<meta itemprop="width" content="720">
		<meta itemprop="height" content="160">
		</div>
		<meta itemprop="name" content="Pokeritaliaweb">
		
	</div>
																		<div class='article-body' itemprop="articleBody">
			<span class="small">Pubblicato il <span datetime="2020-10-24 07:59:25" itemprop="datePublished">24/10/2020</span> da <a href="/component/contact/contact/3.html?Itemid=101">Tiberio "Boss" Redaelli</a></span>
			<meta itemprop="dateModified" content="2020-10-24 08:00:28">
			
				
			<strong><p>L'ha vinto 'kurt111190' il torneo più "importante" del venerdì sera. A segno anche 'S1mba98', protagonista nel Need for Speed Turbo, mentre 'BARONE' e 'sikkio81' si sono praticamente divisi l'Afternoon on Stars.</p>
</strong>
						<div class="fastsocialshare_container fastsocialshare-align-left"><div class="fastsocialshare-subcontainer"><div class="fastsocialshare-share-fbl button_count">						<div id="fb-root"></div>
						<script>
						var loadAsyncDeferredFacebook = function() {
							(function(d, s, id) {
							  var js, fjs = d.getElementsByTagName(s)[0];
							  if (d.getElementById(id)) return;
							  js = d.createElement(s); js.id = id;
							  js.src = "//connect.facebook.net/it_IT/sdk.js#xfbml=1&version=v3.0";
							  fjs.parentNode.insertBefore(js, fjs);
							}(document, 'script', 'facebook-jssdk'));
						}

				  		if (window.addEventListener)
							window.addEventListener("load", loadAsyncDeferredFacebook, false);
						else if (window.attachEvent)
							window.attachEvent("onload", loadAsyncDeferredFacebook);
						else
					  		window.onload = loadAsyncDeferredFacebook;
						</script>
				<div class="fb-like"
					data-href="http://www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html"
					data-layout="button_count"
                	data-width="100"
					data-action="like"
					data-show-faces="false"
					data-share="false">
				</div></div><div class="fastsocialshare-share-fbsh">
    					<a style="background-color:#3B5998; color:#FFFFFF !important;" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.pokeritaliaweb.org%2Fpoker-online%2Fpoker-mtt-report%2F35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html','fbshare','width=480,height=100')" href="javascript:void(0)"><span>f</span><span>Condividi</span></a>
    					
						</div><div class="fastsocialshare-share-tw">
						<a href="https://twitter.com/share" class="twitter-share-button"  data-text=" Poker online MTT - A kurt111190 il NoS, S1mba98 si prende il Need for Speed. Deal tra RJ BARONE e sikkio81 nell&#039;AoS" data-count="horizontal" data-via="" data-url="http://www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html" data-lang="it">Tweet</a>
						</div>
						<script>
							var loadAsyncDeferredTwitter =  function() {
	            						var d = document;
	            						var s = 'script';
	            						var id = 'twitter-wjs';
					            		var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){
						        		js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}
					        		}
						
							if (window.addEventListener)
								window.addEventListener("load", loadAsyncDeferredTwitter, false);
							else if (window.attachEvent)
								window.attachEvent("onload", loadAsyncDeferredTwitter);
							else
								window.onload = loadAsyncDeferredTwitter;
						</script></div></div> 
<p> </p>
<p>Ma iniziamo il nostro report giornaliero sugli MTT online dal Night on Stars, 286 entries per oltre 25.000 euro di montepremi totale, dove 'kurt111190' si è messo in tasca i 4.894 euro del bottino al termine di un ultimo tavolo in cui erano in corsa, tra gli altri, il runner up 'u_PruPPu' (€3.587) e il terzo classificato 'hairfun14' (€2.629).<br /><br />L'ha incassato invece lo scatenato 'S1mba98' il primo premio da 2.330 euro proposto dal Need for Speed Turbo (112 entries per 10.080 euro in prize pool). In questo l'ultimo a mollare è stato 'SpeedOne1' (€1.724) mentre si è arreso una volta salito sul podio il comunque positivo 'DEDOPIU' (€1.276). Tra i migliori anche il regular Andrea 'Andreacigna' Pini che ha chiuso ottavo per 284 euro.<br /><br />E chiudiamo con l'Afternoon on Stars del pomeriggio (233 entries con 50 euro di buy in) che ha registrato il deal quasi alla pari tra 'BARONE' e 'sikkio81'. I 2 si sono divisi circa 1.750 euro a testa una volta eliminati gli altri finalisti '4Didon02' (€1.086), Marco 'pokergus83' Gemma (€796), 'ioticallo' (€583), 'CIPROMCFLY16' (€428), 'cantalupense' (€313), 'UnwelcomE5' (€230) e 'MrMarlboro94' (€230).<br /><br />Per tutti gli altri risultati online e live restate "sintonizzati" con la nostra home o entrate nel canale Telegram <a href="https://t.me/notiziepoker">Notizie Poker</a>.<br /><br />I numeri più importanti dei 3 tornei:<br /><br /><strong>Night on Stars [€15.000 GTD]</strong><br /><strong>Buy-in: €100</strong><br /><strong>Entries: 286</strong><br /><strong>Montepremi Totale: €25.740</strong><br /><span style="text-decoration: underline;"><strong>Final Table Pay Out</strong></span><br /><br />kurt111190 - €4.894<br />u_PruPPu - €3.587<br />hairfun14 - €2.629<br />bovierinho - €1.927<br />bombolo75 - €1.413<br />skertel23 - €1.035<br />IlWlad - €759<br />sribonne - €556<br />shex88 - €408<br /><br /><strong>Need for Speed Turbo [€5.000 GTD]</strong><br /><strong>Buy-in: €100</strong><br /><strong>Entries: 112</strong><br /><strong>Montepremi Totale: €10.080</strong><br /><span style="text-decoration: underline;"><strong>Final Table Pay Out</strong></span><br /><br />S1mba98 - €2.330<br />SpeedOne1 - €1.724<br />DEDOPIU - €1.276<br />micidial88 - €945<br />marino28 - €699<br />WJuveCR7 - €518<br />madda4ever - €383<br />Andrea 'Andreacigna' Pini - €284<br />stammchinevuai - €251<br /><br /><strong>Afternoon on Stars [€7.500 GTD]</strong><br /><strong>Buy-in: €50</strong><br /><strong>Entries: 233</strong><br /><strong>Montepremi Totale: €10.485</strong><br /><span style="text-decoration: underline;"><strong>Final Table Pay Out</strong></span><br /><br />RJ BARONE - €1.702*<br />sikkio81 - €1.801*<br />4Didon02 - €1.086<br />Marco 'pokergus83' Gemma - €796<br />ioticallo - €583<br />CIPROMCFLY16 - €428<br />cantalupense - €313<br />UnwelcomE5 - €230<br />MrMarlboro94 - €230<br /><br />*Deal</p><div class="fastsocialshare_container fastsocialshare-align-left"><div class="fastsocialshare-subcontainer"><div class="fastsocialshare-share-fbl button_count">						<div id="fb-root"></div>
						<script>
						var loadAsyncDeferredFacebook = function() {
							(function(d, s, id) {
							  var js, fjs = d.getElementsByTagName(s)[0];
							  if (d.getElementById(id)) return;
							  js = d.createElement(s); js.id = id;
							  js.src = "//connect.facebook.net/it_IT/sdk.js#xfbml=1&version=v3.0";
							  fjs.parentNode.insertBefore(js, fjs);
							}(document, 'script', 'facebook-jssdk'));
						}

				  		if (window.addEventListener)
							window.addEventListener("load", loadAsyncDeferredFacebook, false);
						else if (window.attachEvent)
							window.attachEvent("onload", loadAsyncDeferredFacebook);
						else
					  		window.onload = loadAsyncDeferredFacebook;
						</script>
				<div class="fb-like"
					data-href="http://www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html"
					data-layout="button_count"
                	data-width="100"
					data-action="like"
					data-show-faces="false"
					data-share="false">
				</div></div><div class="fastsocialshare-share-fbsh">
    					<a style="background-color:#3B5998; color:#FFFFFF !important;" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.pokeritaliaweb.org%2Fpoker-online%2Fpoker-mtt-report%2F35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html','fbshare','width=480,height=100')" href="javascript:void(0)"><span>f</span><span>Condividi</span></a>
    					
						</div><div class="fastsocialshare-share-tw">
						<a href="https://twitter.com/share" class="twitter-share-button"  data-text=" Poker online MTT - A kurt111190 il NoS, S1mba98 si prende il Need for Speed. Deal tra RJ BARONE e sikkio81 nell&#039;AoS" data-count="horizontal" data-via="" data-url="http://www.pokeritaliaweb.org/poker-online/poker-mtt-report/35484-poker-online-kurt111190-nos-s1mba98-prende-need-for-speed-deal-rjbarone-sikkio81-aos.html" data-lang="it">Tweet</a>
						</div>
						<script>
							var loadAsyncDeferredTwitter =  function() {
	            						var d = document;
	            						var s = 'script';
	            						var id = 'twitter-wjs';
					            		var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){
						        		js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}
					        		}
						
							if (window.addEventListener)
								window.addEventListener("load", loadAsyncDeferredTwitter, false);
							else if (window.attachEvent)
								window.attachEvent("onload", loadAsyncDeferredTwitter);
							else
								window.onload = loadAsyncDeferredTwitter;
						</script></div></div>		</div>		
		
	</div>
	<div class="right-article col-sm-3 no-right-padding">
			
					
			
		
					<h3>Storie correlate</h3>
				
											
						
							<div class="article-related"><div class="images-related"><a target="_blank" href="https://t.me/notiziepoker"><img src="/images/bimages/BANNER_POKER_300X250-02.jpg" alt="Telegram 2" /></a></div><h2><a target="_blank" href="https://t.me/notiziepoker"><p>Tutte le notizie e le informazioni sul mondo del poker live ed online</p></a></h2></div>						
				
			
											
			
							<div class='article-related'>
															<div class="images-related">
						<img src='/images/articoli/simone_speranza_relax_800.jpg' alt='Simone 'spera91' Speranza (a destra), 3° nel Night on Stars Super KO' />
					</div>
										<h2><a href="/poker-online/poker-mtt-report/35482-poker-online-cerbokevin94-brucia-elestars-simone-spera91-speranza-nos-super-ko-need-for-speed-mago1981.html">
						Poker online - cerbokevin94 brucia elestars e Simone spera91 Speranza nel NoS Super KO, il Need for Speed va a mago1981					</a></h2>
				</div>
																				
			
							<div class='article-related'>
															<div class="images-related">
						<img src='/images/articoli/matteo_sgrillex_sarais_new800.jpg' alt='Matteo 'sgrillex' Sarais' />
					</div>
										<h2><a href="/poker-online/poker-mtt-report/35480-poker-online-super-indignato94-prende-nos-need-for-speed-matteo-sgrillex-sarais-vince-aos.html">
						Poker online - Un super Indignato94 si prende NoS e Need for Speed, Matteo sgrillex Sarais vince l'AoS					</a></h2>
				</div>
																				
			
							<div class='article-related'>
															<div class="images-related">
						<img src='/images/articoli/angelo_mirko313_patane_800.jpg' alt='Angelo 'Mirko313' Patanè, runner up nel NoS vinto da 'Freogan'' />
					</div>
										<h2><a href="/poker-online/poker-mtt-report/35478-poker-online-freogan-shotta-nos-runner-up-angelo-patane-split-ale-cenciarini-ettore-esposito-need-for-speed.html">
						Poker online - Freogan shotta il NoS, runner up Angelo Patanè. Split tra Ale Cenciarini ed Ettore Esposito nel Need for Speed					</a></h2>
				</div>
																				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
															
						
						
				
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
											
			
														<div class="clear"></div>
	</div>
	<div class="clear"></div>
	
			<div class='title-uppercase'>
		Parliamo anche di:
	</div>
		<div class="padding-laterale-15">
					 	<ul class="tags inline">
																	<li class="tag-8 tag-list0" itemprop="keywords">
					<a href="/component/tags/tag/poker-online.html" class="label label-info">
						Poker online					</a>
				</li>
																				<li class="tag-82 tag-list1" itemprop="keywords">
					<a href="/component/tags/tag/night-on-stars.html" class="label label-info">
						Night on Stars					</a>
				</li>
																				<li class="tag-83 tag-list2" itemprop="keywords">
					<a href="/component/tags/tag/need-for-speed.html" class="label label-info">
						Need for Speed					</a>
				</li>
																				<li class="tag-116 tag-list3" itemprop="keywords">
					<a href="/component/tags/tag/telegram.html" class="label label-info">
						telegram					</a>
				</li>
																				<li class="tag-304 tag-list4" itemprop="keywords">
					<a href="/component/tags/tag/deal.html" class="label label-info">
						Deal					</a>
				</li>
																				<li class="tag-817 tag-list5" itemprop="keywords">
					<a href="/component/tags/tag/nos.html" class="label label-info">
						NoS					</a>
				</li>
																				<li class="tag-1951 tag-list6" itemprop="keywords">
					<a href="/component/tags/tag/afternoon-on-stars.html" class="label label-info">
						Afternoon on Stars					</a>
				</li>
																				<li class="tag-2075 tag-list7" itemprop="keywords">
					<a href="/component/tags/tag/notizie-poker.html" class="label label-info">
						Notizie Poker					</a>
				</li>
																				<li class="tag-2257 tag-list8" itemprop="keywords">
					<a href="/component/tags/tag/aos.html" class="label label-info">
						AoS					</a>
				</li>
						</ul>
		</div>
		<div class='title-uppercase'>
		Notizie correlate
	</div>
						
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
					<div class="col-sm-4"><div class="article-related-bottom"><div class="images-related-bottom"><a target="_blank" href="https://t.me/notiziepoker"><img src="/images/bimages/BANNER_POKER_300X250-02.jpg" alt="Telegram 2" /></a><h2><a target="_blank" href="https://t.me/notiziepoker"><p>Tutte le notizie e le informazioni sul mondo del poker live ed online</p></a></h2></div></div></div>			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/poker_online_mtt2017.jpg' alt='Super 'caramellagommos' nel Sunday Speciale' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35476-poker-online-caramellagommos-sunday-special-blz2412-vince-need-annullato-night-on-stars.html">
					Poker online - A caramellagommos il Sunday Special, blz2412 vince il Need. Annullato il Night on Stars				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/dario_minieri_wsop_800.jpg' alt='Dario 'D.Minieri' Minieri' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35474-poker-online-dario-minieri-torna-vincere-suo-high-roller-gioggi66-comanda-sunday-special.html">
					Poker online - Dario Minieri torna a vincere, suo l'High Roller. Gioggi66 comanda nel Sunday Special				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/poker_online_mtt2017.jpg' alt='I risultati degli MTT online più importanti del sabato...' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35473-poker-online-mtt-nos-gabrielepat-timbrano-anche-suckkkkk-pellegrinous.html">
					Poker online MTT - NoS a gabrielepat, timbrano anche Suckkkkk e Pellegrinous				</a></h2>
			</div>
			</div>
															
		
			
		
					<div class="col-sm-4"><div class="article-related-bottom"><div class="images-related-bottom"><a target="_blank" href="https://t.me/notiziepoker"><img src="/images/bimages/BANNER_POKER_300X250-01.jpg" alt="Telegram 1" /></a><h2><a target="_blank" href="https://t.me/notiziepoker"><p>Tutte le notizie e le informazioni sul mondo del poker live ed online</p></a></h2></div></div></div>			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/andrea_montrone_tavolo_800.jpg' alt='Andrea 'AMW91' Montrone ' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35472-poker-online-venerdi-sera-protagonisti-allacass4-dezva-bene-anche-andrea-montrone-gianluigi-giuliani-chiero83-allin230.html">
					Poker online MTT - Venerdì sera da protagonisti per AllaCass4 e Dezva. Bene anche Andrea Montrone, Gianluigi Giuliani, chiero83 e all in230				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/ettore_profumato87_esposito_new800.jpg' alt='Ettore 'pro-fumato87' Esposito' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35470-poker-online-ciina92-nos-super-ko-giovedi-sera-podio-ettore-profumato87-esposito-spens17.html">
					Poker online - A ciina92 il NoS Super KO del giovedì sera, podio per Ettore pro-fumato87 Esposito e Spens17				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/thomas-zavaroni-800.jpg' alt='Thomas 'zawarella' Zavaroni, tra i protagonisti del NoS' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35468-poker-online-super-deal-nos-molly182-prende-need-for-speed-turbo-aos-santacapa2.html">
					Poker online - Super deal nel NoS, molly_182 si prende il Need for Speed. L'Afternoon on Stars va a SantaCapa2				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/manlio-iemina.jpg' alt='Manlio 'M.I.1980' Iemina' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35466-poker-online-nos-sailonwave-manlio-mi1980-iemina-firma-need-for-speed.html">
					Poker online - NoS a SailonWave, Manlio M.I.1980 Iemina firma il Need for Speed				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
					<div class="col-sm-4">
			<div class='article-related-bottom'>
												<div class="images-related-bottom">
					<img src='/images/articoli/raffaele_sorrentino_barcellona_800.jpg' alt='Raffaele 'raffibiza' Sorrentino, 2° nel Need for Speed Turbo' />
				</div>
								<h2><a href="/poker-online/poker-mtt-report/35464-poker-online-kojex-visodan610-vincono-sunday-special-evening-nos-gazasparta9-blz2412-firma-need-for-speed.html">
					Poker online - kojex e Viso D'an610 vincono Sunday Special ed Evening. Il NoS va a Gaza Sparta9, blz2412 firma il Need for Speed				</a></h2>
			</div>
			</div>
															
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
											
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
								
		
			
		
			
			
									<div class="clear"></div>
	
															<div class="thumbs-miscinfo">
			<div class="contact-thumbs">
				<div class="profile-thumbs">
				<i class="fa fa-4x fa-user" aria-hidden="true"></i>
				</div>
			</div>
			<div class="contact-miscinfo">
				<div>
				<div class="contact-name">
					<a href='index.php?option=com_contact&view=contact&id=3'>Tiberio "Boss" Redaelli</a>
				</div>
				<div>
					<i class='fa fa-google-plus' aria-hidden='true'></i>
					<i class="fa fa-long-arrow-right" aria-hidden="true"></i>
					<a target="_new" href="https://plus.google.com/109004110192613919535?hl=it?rel=author" target="_blank">Visita il mio profilo</a>
				</div>
				<div>
					<i class='fa fa-envelope-o' aria-hidden='true'></i>
					<i class="fa fa-long-arrow-right" aria-hidden="true"></i>
					reda@pokeritaliaweb.org				</div>
				<div class="contact-misc">
									</div>
				</div>
			</div>
			<div class="clear"></div>
		</div>
		<div class="clear"></div>
					
					
</div>

					</div>
		
		
				<div class="right col-sm-mod-3 col-sm-3 right-padding">
					<div class="moduletable_rightBanner">
						<div class="bannergroup_rightBanner">

	<div class="banneritem">
																																																																			<a
							href="/component/banners/click/30.html" target="_blank" rel="noopener noreferrer"
							title="Telegram 1">
							<img
								src="http://www.pokeritaliaweb.org/images/bimages/BANNER_POKER_300X250-01.jpg"
								alt="Telegram 1"
																							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
		</div>
			<div class="moduletable_right">
						<div class="category-module_right">
							
									<div class="mod-articles-category-image">							
						<a href="/piw-editoriali/35108-poker-editoriale-quanto-tempo-durera-il-nuovo-boom-del-poker-online-in-italia.html">
							<img src='/images/federico-cirillo-postazione.jpg' />
						</a>
					</div>
					<div class="mod-articles-category-title">
						<a href="/poker-live/editoriali">
							Editoriali						</a>	
					</div>
					<div class="mod-articles-article-title">
						<a href="/piw-editoriali/35108-poker-editoriale-quanto-tempo-durera-il-nuovo-boom-del-poker-online-in-italia.html">
							Poker Editoriale: quanto tempo durerà il nuovo boom del poker online in Italia?						</a>				
					</div>		
							</div>
		</div>
			<div class="moduletable_betitalia">
						<div class="category-module-tabbed"><div data-module="_betitalia" class="tabbed-0 col-sm-4 mod-articles-category-group active">Pronostici di Calcio Serie A Gratis di Oggi e di Domani</div><div data-module="_betitalia" class="tabbed-1 col-sm-4 mod-articles-category-group hidden-xs">Pronostici sul Calciomercato</div><div data-module="_betitalia" class="tabbed-2 col-sm-4 mod-articles-category-group hidden-xs">Pronostici Tennis ATP/WTA</div><div class="clear"></div><ul class="ul-_betitalia ul-0 "><li><div class="mod-articles-category-image"><div class="logo-bridge"><img src="/images/menu/betitalia.png" alt="Logo" /></div><a target="_new" href="https://www.betitaliaweb.it/pronostici/calcio/serie-a/28590-scommesse-23-24-25-26-ottobre-2020.html"><img src="https://www.betitaliaweb.it/images/licensed/calcio/serie-a/Roma-Dzeko_800x600.jpg" /></a></div><div class="mod-articles-category-title"><a target="_new" href="https://www.betitaliaweb.it/pronostici/calcio/serie-a/28590-scommesse-23-24-25-26-ottobre-2020.html">Pronostici di Calcio Serie A Gratis di Oggi e di Domani</a></div><div class="mod-articles-article-title"><a target="_new" href="https://www.betitaliaweb.it/pronostici/calcio/serie-a/28590-scommesse-23-24-25-26-ottobre-2020.html">Pronostici Serie A: tutto sulla 5a giornata di campionato, si inizia con Sassuolo-Torino. Milan-Roma il big match di lunedì</a></div></li></ul><ul class="ul-_betitalia ul-1 "><li><div class="mod-articles-category-image"><div class="logo-bridge"><img src="/images/menu/betitalia.png" alt="Logo" /></div><a target="_new" href="https://www.betitaliaweb.it/calciomercato/28584-quote-22-10-2020.html"><img src="https://www.betitaliaweb.it/images/licensed/calcio/serie-a/Juventus_Sarri.png" /></a></div><div class="mod-articles-category-title"><a target="_new" href="https://www.betitaliaweb.it/calciomercato/28584-quote-22-10-2020.html">Pronostici sul Calciomercato</a></div><div class="mod-articles-article-title"><a target="_new" href="https://www.betitaliaweb.it/calciomercato/28584-quote-22-10-2020.html">Scommesse Calciomercato: Maurizio Sarri riparte dalla Fiorentina? Secondo i bookmakers sì, ma in quota rimangono vive le alternative Roma e PSG</a></div></li></ul><ul class="ul-_betitalia ul-2 "><li><div class="mod-articles-category-image"><div class="logo-bridge"><img src="/images/menu/betitalia.png" alt="Logo" /></div><a target="_new" href="https://www.betitaliaweb.it/pronostici/tennis/atp-wta/28465-roma-internazionali-d-italia-2020.html"><img src="https://www.betitaliaweb.it/images/licensed/tennis/Tennis-Rafael-Nadal_800x600.jpg" /></a></div><div class="mod-articles-category-title"><a target="_new" href="https://www.betitaliaweb.it/pronostici/tennis/atp-wta/28465-roma-internazionali-d-italia-2020.html">Pronostici Tennis ATP/WTA</a></div><div class="mod-articles-article-title"><a target="_new" href="https://www.betitaliaweb.it/pronostici/tennis/atp-wta/28465-roma-internazionali-d-italia-2020.html">Scommesse Tennis: si gioca a Roma per gli Internazionali d'Italia 2020. Vediamo programma, quote antepost, favoriti e free pick</a></div></li></ul></div>		</div>
			<div class="moduletable_right">
						<div class="category-module_right">
							
									<div class="mod-articles-category-image">							
						<a href="/strategie/135-scuola-poker/30540-poker-e-strategia-come-accorgersi-quando-sei-in-una-brutta-bad-run-o-giochi-male.html">
							<img src='/images/articoli/citta/grinder-poker-800x600.jpg' />
						</a>
					</div>
					<div class="mod-articles-category-title">
						<a href="/strategie-poker/scuola-poker">
							Scuola poker						</a>	
					</div>
					<div class="mod-articles-article-title">
						<a href="/strategie/135-scuola-poker/30540-poker-e-strategia-come-accorgersi-quando-sei-in-una-brutta-bad-run-o-giochi-male.html">
							Poker e Strategia: come accorgersi quando sei in una brutta bad run o giochi male?						</a>				
					</div>		
							</div>
		</div>
			<div class="moduletable_right">
						<div class="category-module_right">
							
									<div class="mod-articles-category-image">							
						<a href="/poker-live/poker-estero/34611-brasile-rio-de-janeiro-poker-mental-game.html">
							<img src='/images/articoli/wsop_millionaire_maker.jpg' />
						</a>
					</div>
					<div class="mod-articles-category-title">
						<a href="/poker-live/poker-estero">
							Poker Estero						</a>	
					</div>
					<div class="mod-articles-article-title">
						<a href="/poker-live/poker-estero/34611-brasile-rio-de-janeiro-poker-mental-game.html">
							Brasile, Rio de Janeiro: poker riconosciuto come Mental Game						</a>				
					</div>		
							</div>
		</div>
			<div class="moduletable_right">
						<div class="category-module_right">
							
									<div class="mod-articles-category-image">							
						<a href="/poker-online/35351-poker-online-mtt-super-deal-nos-ilgreco7-vince-daily-main-pko-micromillions.html">
							<img src='/images/articoli/andrea_briganti_papuasiano_800.jpg' />
						</a>
					</div>
					<div class="mod-articles-category-title">
						<a href="/poker-online">
							Poker Online						</a>	
					</div>
					<div class="mod-articles-article-title">
						<a href="/poker-online/35351-poker-online-mtt-super-deal-nos-ilgreco7-vince-daily-main-pko-micromillions.html">
							Poker online MTT - Super deal nel NoS, ilGreco7 vince il Daily Main PKO delle MicroMillions						</a>				
					</div>		
							</div>
		</div>
			<div class="moduletable_rightBanner">
						<div class="bannergroup_rightBanner">

	<div class="banneritem">
																																																																			<a
							href="/component/banners/click/49.html" target="_blank" rel="noopener noreferrer"
							title="Telegram 1">
							<img
								src="http://www.pokeritaliaweb.org/images/bimages/BANNER_POKER_300X250-01.jpg"
								alt="Telegram 1"
																							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
		</div>
	
		</div>
				
		<div class="clear"></div>
		
		<div class="footer">
			<div class="footer-top col-sm-12 col-xs-12 no-padding">
									<ul class="menu nav navbar-nav">
<li class="item-101 default"><a href="/" class="fa fa-home fa-2x"></a></li><li class="item-300 parent"><a href="/poker-live.html" >Poker Live</a></li><li class="item-25 active parent"><a href="/poker-online.html" >Poker Online</a></li><li class="item-76 parent"><a href="/piw-editoriali.html" >Editoriali</a></li><li class="item-56 parent"><a href="/strategie.html" >Strategie</a></li><li class="item-221"><a href="/gioco-online.html" >Gioco Online</a></li><li class="item-370"><a href="https://t.me/notiziepoker" target="_blank">Telegram</a></li><div class="clear"></div></ul>

							</div>
			<div class="clear"></div>
		
			<div class="footer-medium col-sm-4 col-xs-12">
								<div class="logo-footer">
					<img src='http://www.pokeritaliaweb.org/images/logo.png' alt='PIW Logo' title='Piw Logo' />
				</div>
							</div>
			<div class="footer-medium col-sm-4 col-xs-12">
				<h3>Social channel</h3>
				<p>Sono un PiWello e me ne vanto.</p>
											<div class="moduletable_footer">
						<div>
	<ul class="social">
				<li>
			<a href="https://www.facebook.com/pokeritaliawebpiw" target="_new" rel="nofollow">
				<i class="fa fa-2x fa-facebook-square" aria-hidden="true"></i>
			</a>
		</li>
						<li>
			<a href="https://twitter.com/piwelli" target="_new" rel="nofollow">
				<i class="fa fa-2x fa-twitter-square" aria-hidden="true"></i>
			</a>
		</li>
						<li>
			<a href="https://plus.google.com/114582398996721909814" target="_new" rel="nofollow">
				<i class="fa fa-2x fa-google-plus-square" aria-hidden="true"></i>
			</a>
		</li>
						<li>
			<a href="https://www.linkedin.com/groups/3962496" target="_new" rel="nofollow">
				<i class="fa fa-2x fa-linkedin-square" aria-hidden="true"></i>
			</a>
		</li>
								<li>
			<a href="https://www.youtube.com/user/PokerItaliaWeb" target="_new" rel="nofollow">
				<i class="fa fa-2x fa-youtube-square" aria-hidden="true"></i>
			</a>
		</li>
			</ul>
</div>
		</div>
	
							</div>
			<div class="footer-medium col-sm-4 col-xs-12">
				<h3>Additional information</h3>
											<div class="moduletable">
						<ul class="menu ">
<li class="item-297"><a href="/privacy-e-cookie.html" >Privacy e Cookie</a></li><li class="item-298"><a href="/gioco-responsabile.html" >Gioco responsabile</a></li><li class="item-98"><a href="/chi-siamo.html" >Chi Siamo</a></li><li class="item-299"><a href="/redazione.html" >Redazione</a></li><li class="item-327"><a href="/contattaci.html" >Contattaci</a></li><li class="item-333"><a href="/cerca.html" >Cerca</a></li><div class="clear"></div></ul>
		</div>
	
							</div>
			<div class="clear"></div>
		
			<div class="footer-bottom col-sm-12 col-xs-12">
				<div class="footer-left">
				Copyright <strong>POKERITALIAWEB</strong> - 2007/2020 - P.IVA e C.F. 04450280757
				</div>
			</div>
			<div class="clear"></div>
		</div>
		</div>
	</div>
		<!--googleoff: all-->
			<style type="text/css">  
			.jb.decline.link {
				color: #37a4fc;
				padding: 0;
			}
		</style>
		<!-- Template Decline -->
		<div class="jb cookie-decline " style="display: none;">
			<p>
				Al fine di fornire la migliore esperienza online questo sito utilizza i cookies.				<span class="btn btn-link jb decline link">Elimina i cookie</span>
			</p>
		</div>
				<!-- Template Default bootstrap -->
		<div class="jb cookie bottom black blue ">
		    
			<!-- BG color -->
			<div class="jb cookie-bg black"></div>
		    
			<h2>Al fine di fornire la migliore esperienza online questo sito utilizza i cookies.</h2>
		     
			<p>Utilizzando il nostro sito, l'utente accetta il nostro utilizzo da parte dei cookie.															<a href="/privacy-e-cookie.html">Scopri di più</a>
												</p>
		    
			<div class="btn btn-primary jb accept blue">Accetto</div>
		    
		</div>
		
			
		<!--googleon: all-->
	
	<script type="text/javascript">
	    jQuery(document).ready(function () { 
			function setCookie(c_name,value,exdays)
			{
				var exdate=new Date();
				exdate.setDate(exdate.getDate() + exdays);
				var c_value=escape(value) + ((exdays==null) ? "" : "; expires="+exdate.toUTCString()) + "; path=/";
				document.cookie=c_name + "=" + c_value;
			}
			
			function readCookie(name) {
				var nameEQ = name + "=";
				var jb = document.cookie.split(';');
				for(var i=0;i < jb.length;i++) {
					var c = jb[i];
					while (c.charAt(0)==' ') c = c.substring(1,c.length);
						if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
					}
				return null;
			}
		    
			var $jb_cookie = jQuery('.jb.cookie');
			var $jb_infoaccept = jQuery('.jb.accept');
			var jbcookies = readCookie('jbcookies');
			if(!(jbcookies == "yes")){
				$jb_cookie.delay(1000).slideDown('fast'); 
				$jb_infoaccept.click(function(){
					setCookie("jbcookies","yes",90);
					$jb_cookie.slideUp('slow');
					jQuery('.jb.cookie-decline').fadeIn('slow', function() {});
				});
			}

			jQuery('.jb.decline').click(function(){
				setCookie("jbcookies","",0);
				window.location.reload();
			});
	    });
	</script>


	<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-1531410-1', 'auto');
  ga('send', 'pageview');

</script>
</body>
</html>
